Hledat články

Požadavky skriptu

  • Minimální požadavky
       - Minimum PHP 5.6.31 a novější
       - PHP rozšíření: gd2, curl, iconv
       - MySQLi rozšíření
       - Safe mode musí být OFF
       - Register Globals musí být OFF
       - Magic Quotes musí být OFF
       - Memory limit: 32M+
       - Sendmail
       - Zend Optimizer nesmí být instalován
       - OpenSSL povoleno
       - Nastavení PHP pro upload_max_filesize na 15 a post_max_size na 15

    Doporučené nastavení
       - PHP 7.1 a novější
       - PHP rozšíření: dom

    Nepovinné rozšíření
       - apc (speed boost)
       - bcmath (speed boost)
       - json (speed boost)
       - mbstring (nutné pro neanglickou podporu)

    MySQL databáze
       - Minimum MySQL 4.1.3 a novější (doporučuje se 5.0 a novější)
       - 1 dostupná databáze
       - Podpora InnoDB
       - MySQLi

    Web server
       - Minimálně sdílený hosting na serveru Apache

    Dále je doporučeno
       - Apache - VPS nebo dedikovaný server
       - crontab
       - crontab mod_rewrite (odstraňuje index.php, pro SEO-friendly URLs)
       - memcached (speed boost)
       - mod_security/mod_security2 disabled
       - PHP 7
       - Imagick (vyžadováno pro podporu souborů gif a pro rotaci obrázků v mobilních zařízeních)

    Chat Plugin
    VPS nebo dedikovaný server (sdílený hosting nemusí kapacitně zvládat velké množství uživatelů na chatu v jeden okamžiku)

    Video Plugin
       - FFmpeg (pro konverzi vlastního videa), nicméně bez FFmpeg mohou uživatelé sdílet videa z YouTube nebo Vimeo
       - allow_url_fopen povoleno